我是靠谱客的博主 暴躁玫瑰,最近开发中收集的这篇文章主要介绍Piggy-Bank(完全背包*恰好装满),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

 

Sample Input

 

3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

 

 

Sample Output

 

The minimum amount of money in the piggy-bank is 60.

The minimum amount of money in the piggy-bank is 100.

This is impossible.

      这个问题老师上课刚讲了,就是一个完全背包问题,套模板就可以了(注意模板正确性),还有一点就是恰好装满的最小值的判定,令dp数组全取无穷大,若能恰好取到m,则dp[m]的值已经不是INF了。

代码如下:
 

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<cmath>
#include <algorithm>
#include <stdlib.h>
#include <cstdio>
#include<sstream>
#include<cctype>
#include <set>
#include<queue>
#include <map>
#include <iomanip>
typedef long long ll;
#define  INF  0x3f3f3f3f
using namespace std;
const ll MAX=10010;
ll dp[MAX];
ll c[MAX];
ll v[MAX];
int main()
{
    //freopen("input.txt","r",stdin);
	ll t,n,m,l;
	cin>>t;
	while(t--)
	{
	    memset(c,0,sizeof(c));
	    memset(v,0,sizeof(v));
		cin>>n>>m;m-=n;
		cin>>l;
		fill(dp,dp+m+1,INF);
		for(ll i=1;i<=l;i++)
        {
            cin>>v[i]>>c[i];
        }
        dp[0]=0;//这句要有
        for(ll i=1;i<=l;i++)
        {
            for(ll j=c[i];j<=m;j++)//不能是j=0
            {
                dp[j]=min(dp[j],dp[j-c[i]]+v[i]);
            }
        }
        if(dp[m]!=INF) printf("The minimum amount of money in the piggy-bank is %lld.n",dp[m]);
        else   cout<<"This is impossible."<<endl;

	}
 }

 

 

最后

以上就是暴躁玫瑰为你收集整理的Piggy-Bank(完全背包*恰好装满)的全部内容,希望文章能够帮你解决Piggy-Bank(完全背包*恰好装满)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(53)

评论列表共有 0 条评论

立即
投稿
返回
顶部