我是靠谱客的博主 要减肥菠萝,最近开发中收集的这篇文章主要介绍2015多校联合第六场 hdu5373 The shortest problem 水,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 

Input
Multiple input.
We have two integer n (0<=n<= 104  ) , t(0<=t<= 105 ) in each row.
When n==-1 and t==-1 mean the end of input.
 

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 

Sample Input
  
  
35 2 35 1 -1 -1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 


第一次做 把每一位存到数组中 逐次往前挪 华丽丽的超时了 看标程 发现可以在源数字的基础上只操作数字 好了 用log10()又超时了orz 

得 照着标称做吧 改了一上午加一晚上一直WA 把变量名都换过去了 还不对 开头特判0写成1 一直没看出来!!!长点心吧

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
  //  freopen("cin.txt","r",stdin);
    int n,m,k,l,cas=1;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1) break;
       // printf("n=%d t=%dn",n,t);
        if(m==0)
        {

            if(n%11==0) printf("Case #%d: Yesn",cas++);
            else printf("Case #%d: Non",cas++);
            continue;
        }
        k=n;
        l=0;
        while(k>0)
        {
            l+=k%10;
            k/=10;
        }
        while(m--)
        {
            k=l;
            while(k>0)
            {
                k/=10;
                n*=10;

            }
            n=(n+l)%11;
            k=l;
            while(k>0)
            {
                l+=(k%10);
                k/=10;
            }
        }

      //  printf("%d   ",n);
         if(n==0) printf("Case #%d: Yesn",cas++);
        else  printf("Case #%d: Non",cas++);

    }
    return 0;
}


最后

以上就是要减肥菠萝为你收集整理的2015多校联合第六场 hdu5373 The shortest problem 水的全部内容,希望文章能够帮你解决2015多校联合第六场 hdu5373 The shortest problem 水所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(33)

评论列表共有 0 条评论

立即
投稿
返回
顶部