我是靠谱客的博主 简单皮带,最近开发中收集的这篇文章主要介绍【CUGBACM15级BC第四场 A】hdu 4931 Happy Three FriendsHappy Three Friends,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Happy Three Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1030    Accepted Submission(s): 764


Problem Description
Dong-hao , Grandpa Shawn , Beautful-leg Mzry are good friends. One day , they want to play a game.

There are 6 numbers on the table.

Firstly , Dong-hao can change the order of 6 numbers.

Secondly , Grandpa Shawn take the first one and the last one , sum them up as his scores.

Thirdly , Beautiful-leg Mzry take any of 3 numbers from the last 4 numbers , and sum them up as his scores.

Finally , if Grandpa Shawn's score is larger than Beautiful-leg Mzry's , Granpa Shawn wins!

If Grandpa Shawn's score is smaller than Beautiful-leg Mzry's , Granpa Shawn loses.

If the scores are equal , there is a tie.

Nowadays , it's really sad that Grandpa Shawn loses his love. So Dong-hao wants him to win(not even tie). You have to tell Dong-hao whether he can achieve his goal.
 

Input
There is a number T shows there are T test cases below. ( T <= 50)

For each test case , there are 6 numbers Ai ( 1 <= Ai <= 100 ).
 

Output
If Dong-hao can achieve his goal , output "Grandpa Shawn is the Winner!"
If he can not , output "What a sad story!"
 

Sample Input
  
  
3 1 2 3 3 2 2 2 2 2 2 2 2 1 2 2 2 3 4
 

Sample Output
  
  
What a sad story! What a sad story! Grandpa Shawn is the Winner!
Hint
For the first test case , {3 , 1 , 2 , 2 , 2 , 3} Grandpa Shawn can take 6 at most . But Beautiful-leg Mzry can take 6 too. So there is a tie. For the second test cases , Grandpa Shawn loses. For the last one , Dong-hao can arrange the numbers as {3 , 2 , 2 , 2 , 1 , 4} , Grandpa Shawn can take 7 , but Beautiful-leg Mzry can take 6 at most. So Grandpa Shawn Wins!
 

解题思路:

六个数排序,比较最大的两个数的和  与 第二三四三个数的和  比较

#include <iostream>
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <algorithm>
#include <functional>
#define PI acos(-1)
#define eps 1e-8
#define inf 0x3f3f3f3f
#define debug(x) cout<<"---"<<x<<"---"<<endl
typedef long long ll;
using namespace std;

int a[105];
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        memset(a, 0, sizeof(a));

        for (int i = 0; i < 6; i++)
        {
            scanf("%d", &a[i]);
        }
        sort(a, a + 6, greater<int>());
        int sum1 = a[0] + a[1];
        int sum2 = a[2] + a[3] + a[4];
        if (sum1 > sum2)
        {
            printf("Grandpa Shawn is the Winner!n");
        }
        else
        {
            printf("What a sad story!n");
        }
    }
    return 0;
}



 

最后

以上就是简单皮带为你收集整理的【CUGBACM15级BC第四场 A】hdu 4931 Happy Three FriendsHappy Three Friends的全部内容,希望文章能够帮你解决【CUGBACM15级BC第四场 A】hdu 4931 Happy Three FriendsHappy Three Friends所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部