我是靠谱客的博主 懵懂冷风,最近开发中收集的这篇文章主要介绍【CUGBACM15级BC第30场 A】hdu 5174 Ferries WheelFerries Wheel,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Ferries Wheel
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1804 Accepted Submission(s): 561
Total Submission(s): 1804 Accepted Submission(s): 561
Problem Description
The Ferries Wheel is a circle,rounded by many cable cars,and the cars are numbered
1,2,3...K−1,K
in order.Every cable car has a unique value and
A[i−1]<A[i ]<A[i+1](1<i<K )
.
Today,Misaki invites N friends to play in the Ferries Wheel.Every one will enter a cable car. One person will receive a kiss from Misaki,if this person satisfies the following condition: (his/her cable car's value + the left car's value
) % INT_MAX = the right car's value,the 1st car’s left car is the kth car,and the right one is 2nd car,the kth car’s left car is the (k−1)th car,and the right one is the 1st car.
Please help Misaki to calculate how many kisses she will pay,you can assume that there is no empty cable car when all friends enter their cable cars,and one car has more than one friends is valid.
Today,Misaki invites N friends to play in the Ferries Wheel.Every one will enter a cable car. One person will receive a kiss from Misaki,if this person satisfies the following condition: (his/her cable car's value + the left car's value
) % INT_MAX = the right car's value,the 1st car’s left car is the kth car,and the right one is 2nd car,the kth car’s left car is the (k−1)th car,and the right one is the 1st car.
Please help Misaki to calculate how many kisses she will pay,you can assume that there is no empty cable car when all friends enter their cable cars,and one car has more than one friends is valid.
Input
There are many test cases.
For each case,the first line is a integer N(1<=N<=100) means Misaki has invited N friends,and the second line contains N integers val 1,val 2,...valN , the val [i ] means the ith friend's cable car's value.
(0<=val [i ]<= INT_MAX).
The INT_MAX is 2147483647 .
For each case,the first line is a integer N(1<=N<=100) means Misaki has invited N friends,and the second line contains N integers val 1,val 2,...valN , the val [i ] means the ith friend's cable car's value.
(0<=val [i ]<= INT_MAX).
The INT_MAX is 2147483647 .
Output
For each test case, first output Case #X: ,then output the answer, if there are only one cable car, print "-1";
Sample Input
3 1 2 3 5 1 2 3 5 7 6 2 3 1 2 7 5
Sample Output
Case #1: 1 Case #2: 2 Case #3: 3HintIn the third sample, the order of cable cars is {{1},{2}, {3}, {5}, {7}} after they enter cable car,but the 2nd cable car has 2 friends,so the answer is 3.
题意:有n个朋友,每个朋友可能在k个车厢里的任一个,每个车厢权值是递增的
现在问你,有多少给满足(本身权值+左边权值)%INF=右边权值
思路:因为车厢是递增的,排完序后去重,记下去重后每个权值的个数,表示这个车厢的人的个数,然后直接O(n)枚举一遍即可
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 150
#define mod 2147483647
long long a[N], num[N];
int main()
{
int n, hh = 1;
while (cin >> n)
{
for (int i = 1; i <= n; i++)
{
cin >> a[i];
}
sort(a + 1, a + 1 + n);
int cnt = 1;
num[1] = 1;
for (int i = 2; i <= n; i++)
{
if (a[i] != a[i - 1])
{
a[++cnt] = a[i];
num[cnt] = 1;
}
else
{
num[cnt]++;
}
}
long long ans = 0;
for (int i = 1; i <= cnt; i++)
{
int l, r;
if (i == 1)
{
l = cnt;
}
else
{
l = i - 1;
}
if (i == cnt)
{
r = 1;
}
else
{
r = i + 1;
}
if ((a[i] + a[l]) % mod == a[r])
{
ans += num[i];
}
}
if (cnt == 1)
{
printf("Case #%d: -1n", hh++);
}
else
{
printf("Case #%d: %lldn", hh++, ans);
}
}
return 0;
}
最后
以上就是懵懂冷风为你收集整理的【CUGBACM15级BC第30场 A】hdu 5174 Ferries WheelFerries Wheel的全部内容,希望文章能够帮你解决【CUGBACM15级BC第30场 A】hdu 5174 Ferries WheelFerries Wheel所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复