我是靠谱客的博主 和谐皮带,最近开发中收集的这篇文章主要介绍hdu5360||多校联合第6场1008 贪心,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

http://acm.hdu.edu.cn/showproblem.php?pid=5360

Problem Description
There are  n  soda conveniently labeled by  1,2,,n . beta, their best friends, wants to invite some soda to go hiking. The  i -th soda will go hiking if the total number of soda that go hiking except him is no less than  li  and no larger than  ri . beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than  li  and no larger than  ri , otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n105) , the number of soda. The second line constains  n  integers  l1,l2,,ln . The third line constains  n  integers  r1,r2,,rn (0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of  1,2,,n  denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
  
  
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8
 

/**
hdu5360||多校联合第6场1008  贪心
题目大意:xxx要邀请n个人去玩,对于第i个人如果已经邀请的人数在(li,ri)之间,他就会去。问用怎样的邀请顺序能邀请到最多的人?
解题思路:和去年上海亚洲赛的一道题挺像。我的想法是先将n个人以li递增排个序,然后从前往后遍历,当前已经邀请的为x人,在所有
          li>=x的的人中取ri最小(set维护)的即可。复杂度O(nlogn)
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<set>
using namespace std;
const int maxn=100005;

struct note
{
    int l,r,id;
    bool operator <(const note &other)const
    {
        return l<other.l;
    }
}a[maxn];

int n,num[maxn],flag[maxn];
set<pair<int,int> >st;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i].l);
            a[i].id=i+1;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i].r);
        }
        sort(a,a+n);
        int x=0;
        memset(flag,0,sizeof(flag));
        for(int i=0;;)
        {
            while(x>=a[i].l&&i<n)
            {
                st.insert(make_pair(a[i].r,a[i].id));
                i++;
            }
            while(((*st.begin()).first<x)&&st.size()>0)st.erase(st.begin());
            if(st.size()==0)break;
            int cnt=(*st.begin()).second;
            num[x++]=cnt;
            flag[cnt-1]=1;
            st.erase(st.begin());
        }
        printf("%dn",x);
        for(int i=0;i<n;i++)
        {
            if(!flag[i])
            {
                num[x++]=i+1;
            }
        }
        for(int i=0;i<n;i++)
        {
            printf(i==n-1?"%dn":"%d ",num[i]);
        }
    }
    return 0;
}


最后

以上就是和谐皮带为你收集整理的hdu5360||多校联合第6场1008 贪心的全部内容,希望文章能够帮你解决hdu5360||多校联合第6场1008 贪心所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部