我是靠谱客的博主 认真小懒猪,最近开发中收集的这篇文章主要介绍POJ-1611-The Suspects (简单并查集!),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 23337 Accepted: 11345

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003



第一次做并查集,各种不会,然后看的百度百科的那个并查集,貌似看懂了,但是运用起来就不太一样了

题意:有很多组学生,在同一个组的学生经常会接触,也会有新的同学的加入。但是SARS是很容易传染的,只要在改组有一位同学感染SARS,那么该组的所有同学都被认为得了SARS。现在的任务是计算出有多少位学生感染SARS了。假定编号为0的同学是得了SARS的。

思路:并查集咯,详细看代码!


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

const int maxn = 30005;
int fa[maxn], rank[maxn];//fa[]是根节点,rank[]是 根节点的高度 

int find(int x)  //查找根节点 
{
	if(x != fa[x])
		fa[x] = find(fa[x]);
	return fa[x];
} 

int main()
{
	int n, m, k;
	while(scanf("%d %d", &n, &m), n || m)
	{
		int a, b;
		for(int i = 0; i < n; i++)
		{
			fa[i] = i;
			rank[i] = 0;
		}
		if(m == 0)
		{
			printf("1n");
			continue;
		}
		while(m--)		//输入各个集合 
		{
			scanf("%d", &k);
			k--;
			scanf("%d", &a);
			while(k--)
			{
				scanf("%d", &b);
				a = find(a);
				b = find(b);
				if(rank[a] > rank[b])	//高度更高的为根节点 
				{
					fa[b] = a;
				}
				else 
				{
					fa[a] = b;
					if(rank[a] == rank[b])
						rank[b]++;
				}
				a = b;
			}
		}
		int ans = 0, x = find(0);
		for(int i=0; i<n; i++)
		{
			if(find(i) == x) ans++;  //这里不能写fa[i]==x,会出错,要再更新一次根节点才行 
		}
		printf("%dn", ans);
	}
	return 0;
}




最后

以上就是认真小懒猪为你收集整理的POJ-1611-The Suspects (简单并查集!)的全部内容,希望文章能够帮你解决POJ-1611-The Suspects (简单并查集!)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(46)

评论列表共有 0 条评论

立即
投稿
返回
顶部