我是靠谱客的博主 霸气玫瑰,最近开发中收集的这篇文章主要介绍The Suspects (并查集),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述


    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
    For each case, output the number of suspects in one line.
Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

Sample Output

    4
    1
    1

题意:第一行为两个整数 n 和 m, 其中n是学生的数量, m是团体的数量。每个学生编号是一个0到n-1之间的整数,一开始只有0号学生被视为可能的患者。紧随其后的是团体的成员列表,每组一行。每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。
n = m = 0表示输入结束,不需要处理。
Output
对于每组测试数据, 输出一行可能的患者。

分析:让找出可能的患者,也就是让我们找出和“0”的根节点相同的学生个数。利用并查集不难写出程序。

#include<stdio.h>
int f[30001],m,n;
void init()
{
	int i;
	for(i = 0; i < n; i ++)
		f[i] = i;
	return ;
}
int getf(int v)
{
	if(f[v] == v)
		return v;
	else
	{
		f[v] = getf(f[v]);
		return f[v];
	}
}
void merge(int v, int u)
{
	int t1,t2;
	t1 = getf(v);
	t2 = getf(u);
	if(t1 != t2)
		f[t2] = t1;
	return ;
}
int main()
{
	int i,j,x,y,k,sum;
	while(scanf("%d%d",&n,&m),n != 0 || m != 0)
	{
		sum = 0;
		init();
		for(i = 0; i < m; i ++)
		{
			scanf("%d%d",&k,&x);
			for(j = 0; j < k-1; j ++)
			{
				scanf("%d",&y);
				merge(x,y);
			}
		}
		for(i = 0; i < n; i ++)
			if(getf(i) == f[0])
				sum ++;
		printf("%dn",sum);
	}
	return 0;
}

 

最后

以上就是霸气玫瑰为你收集整理的The Suspects (并查集)的全部内容,希望文章能够帮你解决The Suspects (并查集)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(42)

评论列表共有 0 条评论

立即
投稿
返回
顶部