概述
题目链接:http://poj.org/problem?id=1611点击打开链接
The Suspects
Time Limit: 1000MS | Memory Limit: 20000K | |
Total Submissions: 39369 | Accepted: 19056 |
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4 2 1 2 5 10 13 11 12 14 2 0 1 2 99 2 200 2 1 5 5 1 2 3 4 5 1 0 0 0
Sample Output
4 1 1
判断多少个与0相连就行 这里链接的时候让数值小的当祖先
#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
long long int sum[33333];
int pre[33333];
int findx(int x)
{
int r=x;
while(pre[r]!=r)
{
r=pre[r];
}
int i=x;
int j;
while(pre[i]!=r)
{
j=pre[i];
pre[i]=r;
i=j;
}
return r;
}
int join(int x,int y)
{
int p1=findx(x);
int p2=findx(y);
if(p1<p2)
{
pre[p2]=p1;
sum[p1]+=sum[p2];
}
else if(p1>p2)
{
pre[p1]=p2;
sum[p2]+=sum[p1];
}
}
int main()
{
int n;int m;
while(~scanf("%d%d",&n,&m)&&(n!=0||m!=0))
{
int ans=0;
for(int i=0;i<n;i++)
{
pre[i]=i;
sum[i]=1;
}
for(int i=0;i<m;i++)
{
int t=0;
scanf("%d",&t);
int mid1=-1;int mid2=-1;
while(t--)
{
if(mid1==-1)
scanf("%d",&mid1);
else
{
if(mid2!=-1)
mid1=mid2;
scanf("%d",&mid2);
join(mid1,mid2);
}
}
}
printf("%lldn",sum[0]);
}
}
最后
以上就是傻傻小天鹅为你收集整理的POJ - 1611 The Suspects (并查集)的全部内容,希望文章能够帮你解决POJ - 1611 The Suspects (并查集)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复