我是靠谱客的博主 认真小懒猪,最近开发中收集的这篇文章主要介绍HDOJ1556 树状数组简单应用 Color the ball,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23142    Accepted Submission(s): 11237


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
  
  
1 1 1 3 2 1
 

Author
8600
 

Source
HDU 2006-12 Programming Contest
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1542  1394  1255  2795  3397 

直接贴代码。。。

#include <iostream>
#include <ctime>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 1e5+5;
int n,i,a,b,c[maxn];

int lowbit(int x){
    return x & (-x);
}

int sum(int pos) {
    int x=0;
    while (pos) {
        x += c[pos];
        pos -= lowbit(pos);
    }
    return x;
}

void add(int pos, int num){
     while (pos<=n) {
        c[pos] += num;
        pos += lowbit(pos);
     }
}

int main(){
    while (cin >> n && n) {
        memset(c,0,sizeof(c));
        for (i=1; i<=n; i++) {
            cin >> a >> b;
            add(a,1);
            add(b+1,-1);
        }
        for (i=1; i<n; i++) cout << sum(i)  << " " ;
        cout << sum(n) << endl;
    }
    return 0;
}


最后

以上就是认真小懒猪为你收集整理的HDOJ1556 树状数组简单应用 Color the ball的全部内容,希望文章能够帮你解决HDOJ1556 树状数组简单应用 Color the ball所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(35)

评论列表共有 0 条评论

立即
投稿
返回
顶部