概述
7-4 青蛙跳台阶 (10 分)
一只青蛙一次可以跳上 1 级台阶,也可以跳上2 级。求该青蛙跳上一个n 级的台阶总共有多少种跳法。
输入格式:
首先输入数字n,代表接下来有n组输入,50>=n>=0,然后每行一个数字,代表台阶数,数字为小于60的整数
输出格式:
对每一组输入,输出青蛙的跳法。
输入样例:
3
1
2
3
输出样例:
1
2
3
import java.util.Scanner;
public class Main{
static int n;
static int[] a;
static void Get(){
Scanner hl=new Scanner(System.in);
n=hl.nextInt();
a=new int[n];
for(int i=0;i<n;i++) {
a[i]=hl.nextInt();
}
}
static double Set(int n) {
if(n<=0) {
return 0.0;
}else if(n==1) {
return 1.0;
}else if(n==2) {
return 2.0;
}
double num = 0,numa=1,numb=2;
for(int k=3;k<=n;k++){
num=numa+numb;
numa=numb;
numb=num;
}
return num;
}
public static void main(String[] args) {
Get();
for(int i=0; i<n; i++) {
System.out.println((int)Set(a[i]));
}
}
}
最后
以上就是愤怒狗为你收集整理的7-4 青蛙跳台阶 (10 分)7-4 青蛙跳台阶 (10 分)的全部内容,希望文章能够帮你解决7-4 青蛙跳台阶 (10 分)7-4 青蛙跳台阶 (10 分)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复