我是靠谱客的博主 细心路人,最近开发中收集的这篇文章主要介绍hdu 1019 Least Common Multiple,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296

这题就是一个简单求最小公约数的问题,使用欧几里得算法(辗转相除)求最小公约数;
然后利用公式:两数的乘积=最小公倍数*最大公约数;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
//辗转相除
int gcd(long long a,long long b)
{
if(a<b)
swap(a,b);
return b==0?a:gcd(b,a%b);
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int t;
scanf("%d",&t);
long long b=1,c;
int a;
while(t--)
{
scanf("%d",&a);
c=a*b;
b=c/gcd(a,b);
}
cout<<b<<endl;
}
return 0;
}

最后

以上就是细心路人为你收集整理的hdu 1019 Least Common Multiple的全部内容,希望文章能够帮你解决hdu 1019 Least Common Multiple所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部