我是靠谱客的博主 沉静大炮,最近开发中收集的这篇文章主要介绍hdu1019 Least Common MultipleLeast Common Multiple,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 59825 Accepted Submission(s): 22822
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
#include<stdio.h>
#include<algorithm>
using namespace std;
int LCM(int m,int n)
{
int a,b,c;
a=m,b=n;
while(b!=0)
{
c=a%b;
a=b;
b=c;
}
return m/a*n;//防止溢出
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int num[n];
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
if(n==1) //注意n为1的特殊情况
{
printf("%dn",num[0]);
}
else
{
sort(num,num+n);
for(int i=0;i<n-1;i++)
{
num[i+1]=LCM(num[i],num[i+1]);
}
printf("%dn",num[n-1]);
}
}
return 0;
}
最后
以上就是沉静大炮为你收集整理的hdu1019 Least Common MultipleLeast Common Multiple的全部内容,希望文章能够帮你解决hdu1019 Least Common MultipleLeast Common Multiple所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复