概述
题目描述
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
输入
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
输出
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
样例输入 Copy
2 2 3 5 3 4 6 12
样例输出 Copy
15 12
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string>
using namespace std;
int gcd(int a, int b){
if(b == 0) return a;
else return gcd(b, a % b);
}
int main(int argc, char** argv) {
int n;
while(cin >> n){
for(int i = 0; i < n; i++){
int m;
cin >> m;
int a[m];
for(int j = 0; j < m; j++){
cin >> a[j];
}
int r;
for(int j = 0; j < m - 1; j++){
a[j + 1] = a[j + 1] / gcd(a[j], a[j + 1]) * a[j];//这里先除再乘,不然会溢出
}
cout << a[m - 1] << endl;
}
}
return 0;
}
最后
以上就是眼睛大白羊为你收集整理的问题 A: Least Common Multiple的全部内容,希望文章能够帮你解决问题 A: Least Common Multiple所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复