我是靠谱客的博主 现代店员,最近开发中收集的这篇文章主要介绍ACM-简单题之Least Common Multiple——hdu1019 ***************************************转载请注明出处:http://blog.csdn.net/lttree*************************************** Least Common Multiple,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

***************************************转载请注明出处:http://blog.csdn.net/lttree***************************************


Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28975    Accepted Submission(s): 10905


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
105 10296
 

Source
East Central North America 2003, Practice
 

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1019


这道题就是求一堆数的最小公倍数。

要注意,每一行的第一个数表示后面跟着有几个数。

然后,我的方法是将输入的数存到数组,然后进行从大到小排序。

从头开始判断,如果当前的mul(之前所有数的最小公倍数)是当前数的倍数,就不需要计算这个数了,直接跳过。

最后再注意一点,用__int64来解决,scanf是用:%I64d


/****************************************
*****************************************
*
Author:Tree
*
*From :
blog.csdn.net/lttree
*
* Title : Least Commn Multiple
*
*Source: hdu 1019
*
* Hint :
*
*****************************************
****************************************/
#include <stdio.h>
#include <algorithm>
using namespace std;
__int64 num[10001];
// 求a和b的最小公倍数
__int64 lcm( __int64 a,__int64 b)
{
__int64 x=a,y=b,k;
while( x%y!=0 )
{
k=x%y;
x=y;
y=k;
}
return a*b/k;
}
// 从大到小排序 sort用
bool cmp(__int64 a,__int64 b)
{
return a>b;
}
int main()
{
int t,n,i;
__int64 mul;
scanf("%d",&t);
while( t-- )
{
scanf("%d",&n);
for( i=0;i<n;++i )
scanf("%I64d",&num[i]);
sort(num,num+n,cmp);
mul=num[0];
// 如果当前的最小公倍数是该数的倍数就不需要计算了。
for( i=1;i<n;++i )
if( mul%num[i]!=0 )
mul=lcm(mul,num[i]);
printf("%I64dn",mul);
}
return 0;
}


最后

以上就是现代店员为你收集整理的ACM-简单题之Least Common Multiple——hdu1019 ***************************************转载请注明出处:http://blog.csdn.net/lttree*************************************** Least Common Multiple的全部内容,希望文章能够帮你解决ACM-简单题之Least Common Multiple——hdu1019 ***************************************转载请注明出处:http://blog.csdn.net/lttree*************************************** Least Common Multiple所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(64)

评论列表共有 0 条评论

立即
投稿
返回
顶部