概述
问题 A: Least Common Multiple
时间限制: 1 Sec 内存限制: 32 MB
提交: 830 解决: 369
题目描述
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
输入
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
输出
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
样例输入
2
2 3 5
3 4 6 12
样例输出
15
12
思路
每两个求最小公倍数然后覆盖再原数组里 a*b/gcd
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int gcd(int a,int b){
if(b==0) return a;
else return gcd(b,a%b);
}
int main(){
int n,m,i;
int a[100];
scanf("%d",&n);
while(n--){
scanf("%d",&m);
for(i=0;i<m;i++){
scanf("%d",&a[i]);
}
for( i=1;i<m;i++){
int x=gcd(a[i-1],a[i]);
a[i]=a[i-1]/x*a[i];
}
printf("%dn",a[i-1]); //跳出循环时i为n
}
}
//题目的精髓是依次两两求最小公倍数然后保存
最后
以上就是迷人楼房为你收集整理的2136 Problem A Least Common Multiple的全部内容,希望文章能够帮你解决2136 Problem A Least Common Multiple所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复