我是靠谱客的博主 激情火,最近开发中收集的这篇文章主要介绍HDU5584(LCM Walk),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description

A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!

Input

First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.

⋅ 1≤T≤1000.
⋅ 1≤ex,ey≤109.

Output

For every test case, you should output "Case #x: y", where x indicates the case number and counts from 1 and y is the number of possible starting grids.

Sample Input

3

6 10

6 8

2 8

Sample Output

Case #1: 1

Case #2: 2

Case #3: 3

题意:每次只给出终点坐标(ex,ey),假设当前位置是(x,y),只能向右走或者向下走,下一步只能走到(x+z,y)或者(x,y+z),z=lcm(x,y) 问可以从多少个点出发可以到达终点。

思路:

       设gcd(x,y)=p,x=np,y=mp,lcm(x,y)=nmp,那么下一步能走到(n(m+1)p,mp)或者(np,m(n+1)p),并且由于n(m+1)与m互质,n与m(n+1)互质,所以下一步的gcd依然是p。

        所以先求p=gcd(ex,ey),然后求得x=ex/p;y=ey/p。转化问题到从(a,b)走了一步到(x,y),假设向右平移一步到达的,那么得出就是a=x,(a+1)*b=y,解出a=x,b=y/(x+1),那么且b必须能被整除。同理可以推出向上平移的情况a=x/(y+1),b=y;因为必须都是能够被整除,所以可以发现路径的唯一性。。。算了还是看代码吧。

#include <set>
#include <map>
#include <deque>
#include <stack>
#include <queue>
#include <time.h>
#include <vector>
#include <string>
#include <math.h>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <iomanip>
#include <iostream>
#include <algorithm>
#define PI acos(-1)
#define ll long long
#define inf 0x3f3f3f3f
#define ull unsigned long long
using namespace std;
ll gcd(ll n,ll m)
{
if(m==0) return n;
else return gcd(m,n%m);
}
ll dfs(ll x,ll y)
{
if(x>y) swap(x,y);
ll a=x;
ll b=y/(1+x);
if(b*(1+x)==y) return dfs(a,b)+1;
else return 0;
}
int main()
{
int T;
int Case=0;
scanf("%d",&T);
while(T--)
{
ll x,y;
scanf("%lld%lld",&x,&y);
cout<<"Case #"<<++Case<<": ";
ll p=gcd(x,y);
x=x/p;
y=y/p;
printf("%lldn",dfs(x,y)+1);
}
}

 

最后

以上就是激情火为你收集整理的HDU5584(LCM Walk)的全部内容,希望文章能够帮你解决HDU5584(LCM Walk)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部