概述
LCM Walk
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1329 Accepted Submission(s): 684
Problem Description
A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.
Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy) , and begins his journey.
To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y) , first of all, he will find the minimum z that can be divided by both x and y , and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y) , or (x,y+z) .
After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey) . However, he is too tired and he forgets the position of his starting grid!
It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey) !
Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy) , and begins his journey.
To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y) , first of all, he will find the minimum z that can be divided by both x and y , and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y) , or (x,y+z) .
After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey) . However, he is too tired and he forgets the position of his starting grid!
It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey) !
Input
First line contains an integer
T
, which indicates the number of test cases.
Every test case contains two integers ex and ey , which is the destination grid.
⋅ 1≤T≤1000 .
⋅ 1≤ex,ey≤109 .
Every test case contains two integers ex and ey , which is the destination grid.
⋅ 1≤T≤1000 .
⋅ 1≤ex,ey≤109 .
Output
For every test case, you should output "
Case #x: y", where
x
indicates the case number and counts from
1
and
y
is the number of possible starting grids.
Sample Input
3 6 10 6 8 2 8
Sample Output
Case #1: 1 Case #2: 2 Case #3: 3
Source
2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)
题意:有只青蛙每次可以从(x,y)跳到(x+z,y)或(x,y+z),其中z=lcm(x,y)。现在给出青蛙的终点坐标,求其可能的起点位置的种数。
思路:一开始推的很麻烦,但是还是想到了要从终点开始逆推。之后还是看了题解,首先令上一步的坐标为(x,y),k=gcd(x,y),则上一步的x可以表示为m1k,上一步的y可以表示为m2k,z可以表示为m1m2k,下一步的(x+z,y)即为(m1(1+m2)k,m2k),因为m1,m2,m2+1相互互质,因此下一步的横坐坐标的gcd依旧为k,明白了这点就可以从终点开始反复确定是否可以找到满足条件的上一步。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
int gcd(int a,int b){
return b==0?a:gcd(b,a%b);
}
int main(){
int t;
scanf("%d",&t);
for(int cas=1;cas<=t;cas++){
long long sum=1;
int x,y;
scanf("%d %d",&x,&y);
int k=gcd(x,y);
while(1){
if(x<y)
swap(x,y);
int m1=x/k;
int m2=y/k;
if(m1%(m2+1)==0)
sum++;
else
break;
x=m1/(1+m2)*k;
}
printf("Case #%d: %dn",cas,sum);
}
return 0;
}
最后
以上就是虚拟柚子为你收集整理的HDU 5584 LCM Walk (找规律+逆推)LCM Walk的全部内容,希望文章能够帮你解决HDU 5584 LCM Walk (找规律+逆推)LCM Walk所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复