概述
Bomb
Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.
解题思路:
数位DP模板题呀。
过了这题可以看看我上一篇博客的题。
如出一辙,比那题还少了一层限制。
枚举时区分三种状态:
1、前面已经出现过13 记为状态2
2、前面没出现13但前一位是1 记为状态1
3、前面没出现13且前一位不是1 记为状态0
https://blog.csdn.net/qq_43461168/article/details/103330437
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#define int long long
using namespace std;
int a[20];
int dp[20][5];
int dfs(int pos,int pre,int limit,int flag)
{
if(pos == -1) return (flag == 2);
if(!limit && dp[pos][flag] != -1) return dp[pos][flag];
int up = limit ? a[pos] : 9;
int tmp = 0;
for(int i = 0 ;i <= up ; i ++)
{
tmp += dfs(pos-1,i,limit && a[pos] == i ,
(flag == 2 ? 2 : ((pre == 4 && i == 9) ? 2 : (i == 4 ? 1 : 0) ) ));
}
if(!limit) dp[pos][flag] = tmp;
return tmp;
}
int solve(int x)
{
int pos = 0;
while(x)
{
a[pos++] = x%10;
x /= 10;
}
return dfs(pos-1,0,1,0);
}
signed main()
{
int n,a,b;
memset(dp,-1,sizeof(dp));
cin>>n;
while(n--)
{
cin>>a;
cout<<solve(a)<<endl;
}
return 0;
}
最后
以上就是陶醉哈密瓜为你收集整理的HDU-3555-Bomb(数位DP)的全部内容,希望文章能够帮你解决HDU-3555-Bomb(数位DP)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复