我是靠谱客的博主 文静樱桃,最近开发中收集的这篇文章主要介绍hdu3555----Bomb 数位DP,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

HDU3555----Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4594    Accepted Submission(s): 1601

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15

传送门

题意:求1~N中含有数字49的个数     1 <= N <= 2^63-1
#include <cstdio>  
#include <cstring>  
  
using namespace std;  
  
int bit[25];  
__int64 dp[25][3];  
//dp[i][0]表示长度为i,没有49  
//dp[i][1]表示长度为i,没有49但前一位为4  
//dp[i][2]表示长度为i,包括49的个数  
  
/*limit表示是否有上限,比如n=1234,现在转移到12,如果下一位选3,那么再下一位就有上限, 
上限为4,如果不选3,那么下一位就没限制,最高位9,转移能保证转移到数比n小*/  
  
__int64 Dfs (int pos,int s,bool limit) //s为之前数字的状态  
{  
     if (pos==-1)  
        return s==2;  
     if (limit==false && ~dp[pos][s])  
        return dp[pos][s];  
     int i ,end=limit?bit[pos]:9;  
      __int64 ans=0;  
     for (i=0;i<=end;i++)  
     {  
        int nows=s;  
        if(s==0 && i==4)  
             nows=1;  
        if(s==1 && i!=9) //前一位为4  
             nows=0;  
        if(s==1 && i==4)  
             nows=1;  
        if(s==1 && i==9) //49  
             nows=2;  
         ans+=Dfs(pos-1 , nows , limit && i==end);  
     }  
    //limit==true则说明有限制,即所有可能并没有被全部记录,故此时记入dp数组  
    //limit==false则说明之后的分支状态已经搜索完全  
    return limit?ans:dp[pos][s]=ans;  
}  
  
int main ()  
{  
      __int64 n;  
     int T;  
     memset(dp,-1,sizeof(dp));  
     scanf("%d",&T);  
     while (T--)  
     {  
         scanf("%I64d",&n);  
         int len=0;  
         while (n)  
         {  
             bit[len++]=n%10;  
             n/=10;  
         }  
         printf("%I64dn",Dfs(len-1,0,1));  
     }  
     return 0;  
}  

 

最后

以上就是文静樱桃为你收集整理的hdu3555----Bomb 数位DP的全部内容,希望文章能够帮你解决hdu3555----Bomb 数位DP所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(48)

评论列表共有 0 条评论

立即
投稿
返回
顶部