我是靠谱客的博主 重要外套,最近开发中收集的这篇文章主要介绍文章标题poj 3278 Catch That Cow(bfs实现),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 61611 Accepted: 19259

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
分析:简单的bfs,向三个方向搜索,此题我用两个队列,分别存储到达相应坐标所需相应的步数。

//using bfs 
#include"iostream"
#include"cstdio"
#include"queue"
#include"cstring"
using namespace std;
int n,k;
const int maxk=100000+5;
bool vis[maxk];
int bfs(int start,int ed,int sum){
int ss;
int s1;
int s2;
int s3;
int sum1=0,sum2=0,sum3=0;
queue<int> q;//q用来存储坐标
queue<int> n;//n用来存储步数。n与q相对应,到达q是所用步数为n
q.push(start);
n.push(sum);
while(!q.empty()){
start=q.front();
sum=n.front();
sum++;
if(start==ed)
break;
n.pop();
q.pop();
for(int i=1;i<=3;i++){
if(start==ed)
break;
if(i==1){
ss=start+1;
}
if(i==2){
ss=start-1;
}
if(i==3){
ss=start*2;
}
if(ss>=0&&ss<maxk&&!vis[ss]){
vis[ss]=1;
q.push(ss);
n.push(sum);
}
}
}
return sum-1;//当第一次开始bfs时,sum++,所以此处-1
}
int main(){
while(scanf("%d %d",&n,&k)==2){
memset(vis,false,sizeof(vis));
int num;
vis[n]=1;
num=bfs(n,k,0);
cout<<num<<endl;
}
}

最后

以上就是重要外套为你收集整理的文章标题poj 3278 Catch That Cow(bfs实现)的全部内容,希望文章能够帮你解决文章标题poj 3278 Catch That Cow(bfs实现)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(40)

评论列表共有 0 条评论

立即
投稿
返回
顶部