我是靠谱客的博主 瘦瘦人生,最近开发中收集的这篇文章主要介绍Catch That Cow POJ - 3278 [bfs][最短路]Catch That CowInputOutputSample InputSample OutputHint,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Catch That Cow
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include <iostream>
#include <string>
#include <queue>
using namespace std;
int v[200000]={0};
queue<int> line;
bool judge(int a){ //判断是否可以拓展
if (v[a] == 0 && a >= 0 && a <= 100000 ) return true;
else return false;
}
int main() {
int n,m;
while ( cin >> n >> m) {
int min=100000;
if(n == m) {
cout << '0' << endl;
continue;
}
memset(v, 0, sizeof(v));
while ( !line.empty()) {
line.pop();
}
v[n] = 1;
line.push(n);
int time=0;
int k; //拓展层数
while ( !line.empty()) {
k = line.front();
//
cout << "k:" <<
k;
line.pop();
if( judge(k+1) ) {line.push(k+1); v[k+1] += v[k]+1;}
if( judge(k-1) ) {line.push(k-1);
v[k-1] += v[k]+1;}
if (judge(k*2))
{line.push(k*2);
v[k*2] += v[k]+1;}
}
cout << v[m]-1 <<endl;
}
}
最后
以上就是瘦瘦人生为你收集整理的Catch That Cow POJ - 3278 [bfs][最短路]Catch That CowInputOutputSample InputSample OutputHint的全部内容,希望文章能够帮你解决Catch That Cow POJ - 3278 [bfs][最短路]Catch That CowInputOutputSample InputSample OutputHint所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复