我是靠谱客的博主 端庄热狗,最近开发中收集的这篇文章主要介绍B - Catch That Cow(BFS),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

简单、BFS,注意的是因为有-1,所以状态会有返回并反复将相同的状态装入队列的情况,为了增加效率,防止内存超出,应该标记每次所经历过的状态,防止对同一个状态的多次访问。

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
int n, k;
//int cnt = 0;
int d[100005];
int vis[100005];
int bfs(void)
{
memset(d, -1, sizeof(d));
memset(vis, 0, sizeof(vis));
if(n == k)
return 0;
queue<int> que;
que.push(n);
d[n] = 0;
vis[n] = 1;
while(que.size())
{
int q = que.front();
que.pop();
if(q == k)
break;
if(2 * q < 100005 && vis[2*q] == 0)
{
d[2 * q] = d[q] + 1;
vis[2*q] = 1;
que.push(2*q);
}
if(q + 1 < 100005 && vis[q+1] == 0)
{
d[q+1] = d[q] +1;
vis[q+1] = 1;
que.push(q+1);
}
if(q - 1 >= 0 && vis[q-1] == 0)
{
d[q-1] = d[q] +1;
vis[q-1] =1;
que.push(q-1);
}
}
return d[k];
}
int main()
{
cin>>n>>k;
int cnt = bfs();
cout<<cnt<<endl;
return 0;
}


最后

以上就是端庄热狗为你收集整理的B - Catch That Cow(BFS)的全部内容,希望文章能够帮你解决B - Catch That Cow(BFS)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(90)

评论列表共有 0 条评论

立即
投稿
返回
顶部