概述
这题目和完全背包问题很类似。基本的方程只需将完全背包问题的方程略微一改即可,因为对于第i种物品有n[i]+1种策略:取0件,取1件……取n[i]件。令f[i][v]表示前i种物品恰放入一个容量为v的背包的最大权值,则有状态转移方程:
f[i][v]=max{f[i-1][v-k*c[i]]+k*w[i]|0<=k<=n[i]}
Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
Sample Output
20 10
40 40
这是多重背包,背包的上线时total/2;
代码:
#include<iostream>
using namespace std;
int dp[250025];
int v[100],num[100];
int max( int a,int b )
{
return a > b ? a : b;
}
int main()
{
int i,j,n,sum,cnt,k;
while(scanf("%d",&n),n>0)
{
cnt=0;
for(i=0;i<n;i++){ scanf("%d%d",&v[i],&num[i]);cnt+=v[i]*num[i];}
memset(dp,0,sizeof(dp));
sum=cnt/2;
for(i=0;i<n;i++)
for(j=0;j<num[i];j++)
for(k=sum;k>=v[i];k-=v[i])
dp[k]=max(dp[k],dp[k-v[i]]+v[i]);
if(cnt-dp[sum]>dp[sum])
printf("%d %dn",cnt-dp[sum],dp[sum]);
else printf("%d %dn",dp[sum],cnt-dp[sum]);
}
return 0;
}
最后
以上就是神勇秀发为你收集整理的hdu 1117 Big Event in HDU(多重背包)的全部内容,希望文章能够帮你解决hdu 1117 Big Event in HDU(多重背包)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复