我是靠谱客的博主 迷路马里奥,最近开发中收集的这篇文章主要介绍UVALive2536 POJ1248 HDU1015 ZOJ1403 Safecracker【密码+暴力+水题】,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Safecracker
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3277 Accepted: 1741

Description

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."  

v - w 2  + x 3  - y 4  + z 5  = target  

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9 2  + 5 3  - 3 4  + 2 5  = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."  


"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations.  

Input

Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input.

Output

For each line output the unique Klein combination, or 'no solution' if there is no correct combination. Use the exact format shown below."  

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

Source

Mid-Central USA 2002


Regionals 2002 >> North America - Mid-Central USA


问题链接:UVALive2536 POJ1248 HDU1015 ZOJ1403 Safecracker

问题简述给一个密码值,给一个字符串,找出6个字符使得经过指定的运算之后等于密码值,输出这些字符。

问题分析:这个问题用暴力法来解。

程序说明:(略)

题记:(略)


参考链接:(略)


AC的C++语言程序如下:

/* UVALive2536 POJ1248 HDU1015 ZOJ1403 Safecracker */

#include <iostream>
#include <algorithm>
#include <string>
#include <stdio.h>

using namespace std;

bool cmp(char a,char b)
{
    return a > b;
}

int calc(int v,int w,int x,int y,int z)
{
    return v - w*w + x*x*x - y*y*y*y + z*z*z*z*z;
}

void solve(int target, string& s)
{
    int n = s.length();

    for(int z=0; z<n; z++) {
        for(int y=0; y<n; y++) {
            if(y == z)
                continue;
            for(int x=0; x<n; x++) {
                if(x == z || x == y)
                    continue;
                for(int w=0; w<n; w++) {
                    if(w == z || w == y || w == x)
                        continue;
                    for(int v=0; v<n; v++) {
                        if(v == z || v == y || v == x || v == w)
                            continue;
                        if(calc(s[z]-'A'+1, s[y]-'A'+1, s[x]-'A'+1, s[w]-'A'+1, s[v]-'A'+1) == target) {
                            printf("%c%c%c%c%cn", s[z], s[y], s[x], s[w], s[v]);
                            return ;
                        }
                    }
                }
            }
        }
    }
    printf("no solutionn");
}

int main()
{
    int target;
    string s;

    while(cin >> target >> s && target) {
        sort(s.begin(), s.end(), cmp);
        solve(target, s);
    }

    return 0;
}




最后

以上就是迷路马里奥为你收集整理的UVALive2536 POJ1248 HDU1015 ZOJ1403 Safecracker【密码+暴力+水题】的全部内容,希望文章能够帮你解决UVALive2536 POJ1248 HDU1015 ZOJ1403 Safecracker【密码+暴力+水题】所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(50)

评论列表共有 0 条评论

立即
投稿
返回
顶部