我是靠谱客的博主 义气发夹,最近开发中收集的这篇文章主要介绍POJ2636 HDU2304 ZOJ2807 Electrical Outlets【水题】,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Electrical Outlets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9987 Accepted: 7458

Description

Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy’s apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time.
Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time. The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now.
Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered itself to be of any use.
在这里插入图片描述

Input

Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.

Output

Output one line per test case, with the maximum number of appliances that can be powered.

Sample Input

3
3 2 3 4
10 4 4 4 4 4 4 4 4 4 4
4 10 10 10 10

Sample Output

7
31
37

Source

Nordic 2005

问题链接:POJ2636 HDU2304 ZOJ2807 Electrical Outlets
问题简述:(略)
问题分析
    k个电插排,有关各自的插孔数量,问连在一起还剩下多少插孔?
    k个电插排连在一起需要用掉k-1个插孔。求和就算一下就可以了。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* POJ2636 HDU2304 ZOJ2807 Electrical Outlets */

#include <stdio.h>

int main(void)
{
    int n, k, a, ans;
    scanf("%d", &n);
    while(n--) {
        scanf("%d", &k);

        ans = -(k - 1);
        while(k--) {
            scanf("%d", &a);
            ans += a;
        }

        printf("%dn", ans);
    }

    return 0;
}

最后

以上就是义气发夹为你收集整理的POJ2636 HDU2304 ZOJ2807 Electrical Outlets【水题】的全部内容,希望文章能够帮你解决POJ2636 HDU2304 ZOJ2807 Electrical Outlets【水题】所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(50)

评论列表共有 0 条评论

立即
投稿
返回
顶部