概述
传送门:Risk
Risk
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 2502 | Accepted: 1176 |
Description
Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player's turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.
During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.
The following connection diagram illustrates the first sample input.
During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.
The following connection diagram illustrates the first sample input.
Input
Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest.
There can be multiple test sets in the input file; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.
There can be multiple test sets in the input file; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.
Output
For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.
Sample Input
1 3 2 3 4 3 4 5 6 1 6 1 7 2 12 13 1 8 2 9 10 1 11 1 11 2 12 17 1 14 2 14 15 2 15 16 1 16 1 19 2 18 19 1 20 1 20 5 1 20 2 9 19 5 18 19 16 20
Sample Output
Test Set #1 1 to 20: 7 2 to 9: 5 19 to 5: 6 18 to 19: 2 16 to 20: 2
Source
South Central USA 1997
解题报告:
此题可用floyd做,代码如下:
#include<iostream>
#include<cstdio>
#define INF 1000
using namespace std;
int weight[30][30];
int n;
void floyd(){
for(int t=1;t<=20;t++)
for(int i=1;i<=20;i++)
for(int j=1;j<=20;j++)
weight[i][j]=min(weight[i][j],weight[i][t]+weight[t][j]);
}
int main(){
int k=0;
while(scanf("%d",&n)==1){
for(int i=0;i<30;i++){
for(int j=0;j<30;j++)
weight[i][j]=INF;
weight[i][i]=0;
}
int v;
for(int i=0;i<n;i++){
scanf("%d",&v);
weight[1][v]=weight[v][1]=1;
}
for(int i=2;i<20;i++){
scanf("%d",&n);
for(int j=0;j<n;j++){
scanf("%d",&v);
weight[i][v]=weight[v][i]=1;
}
}
floyd();
scanf("%d",&v);
int x,y;
printf("Test Set #%dn",++k);
for(int i=0;i<v;i++){
scanf("%d%d",&x,&y);
printf("%d to %d: %dn",x,y,weight[x][y]);
}
printf("n");
}
return 0;
}
最后
以上就是曾经外套为你收集整理的[floyd]POJ 1603 Risk的全部内容,希望文章能够帮你解决[floyd]POJ 1603 Risk所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复