我是靠谱客的博主 受伤糖豆,最近开发中收集的这篇文章主要介绍Uva 1292 - Strategic game 树形dp 最小点覆盖,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier (at the node 1).

Input 

The input file contains several data sets in text format. Each data set represents a tree with the following description:
  • the number of nodes
  • the description of each node in the following format:
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 � node_identifiernumber_of_roads
    or
    node_identifier:(0)
The node identifiers are integer numbers between  0  and  n-1 , for  n  nodes ( 0 < n ≤ 1500 ). Every edge appears only once in the input data.

Output 

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).

Sample Input 

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output 

1
2
-------------

f[i][0]表示点i属于点覆盖,并且以点i为根的子树中所连接的边都被覆盖的情况下点覆盖集中所包含的最少点数。

f[i][1]表示点i不属于点覆盖,且以i为根的子树中所连接的边都被覆盖的情况下点覆盖集中所包含最少点的个数。

① f[i][0]=1+sum{ min(f[v][0], f[v][1]) };

② f[i][1]=sum{ f[v][0] };

-------------

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn=3111;
const int INF=1e9;

struct EDGENODE
{
    int to,next;
} edges[maxn];
int head[maxn],edge;
void addedge(int u,int v)
{
    edges[edge].to=v,edges[edge].next=head[u],head[u]=edge++;
    edges[edge].to=u,edges[edge].next=head[v],head[v]=edge++;
}
void init_edges()
{
    memset(head,-1,sizeof(head));
    edge=0;
}
int n;
int f[maxn][2];
void dp(int u,int pa)
{
    f[u][0]=1;
    f[u][1]=0;
    for (int k=head[u]; k!=-1; k=edges[k].next)
    {
        int v=edges[k].to;
        if (v==pa) continue;
        dp(v,u);
        f[u][0]+=min(f[v][0],f[v][1]);
        f[u][1]+=f[v][0];
    }
}

int main()
{
    while (~scanf("%d",&n))
    {
        int u,v,t;
        init_edges();
        for (int i=0; i<n; i++)
        {
            scanf("%d:(%d)",&u,&t);
            while (t--)
            {
                scanf("%d",&v);
                addedge(u,v);
            }
        }
        dp(0,-1);
        printf("%dn",min(f[0][0],f[0][1]));
    }
    return 0;
}







最后

以上就是受伤糖豆为你收集整理的Uva 1292 - Strategic game 树形dp 最小点覆盖的全部内容,希望文章能够帮你解决Uva 1292 - Strategic game 树形dp 最小点覆盖所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(64)

评论列表共有 0 条评论

立即
投稿
返回
顶部