我是靠谱客的博主 土豪乌冬面,最近开发中收集的这篇文章主要介绍2017 计蒜之道 初赛 第三场 A. 腾讯课堂的物理实验,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

传送门


在腾讯课堂的物理课上,进行了一个有趣的物理实验。

在一个长度为 LL 米的光滑轨道上,小车 A 在 00时刻以 1mathrm{m/s}1m/s 的速度从左端出发向右运动,小车 B 在 tt 时刻以 1mathrm{m/s}1m/s 的速度从右端出发向左运动,两个小车的质量相等。假设所有碰撞都是弹性碰撞,也就是当两个小车相向碰撞时,他们各自会以原来的速度向相反的方向运动;小车和轨道两端发生碰撞时,小车会以原速度向反方向运动。

试求出 TT 时刻的时候,两个小车相距多远。

输入格式

输入三个整数 L(1 le L le 1000),L(1L1000), t(0 le t le 1000),t(0t1000), T(t le T le 1000)T(tT1000)

输出格式

输出 TT 时刻两车之间的距离。

样例输入1

10 4 7

样例输出1

0

样例输入2

8 3 9

样例输出2

5


两车相撞是等于两车互换继续行驶。

所以算A车运动了多少距离 B车运动了多少距离两车此时的位置相减就好了

如果<0 取abs

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <bitset>
#include <set>
#include <vector>
#include <functional>
using namespace std;
#define pi acos(-1)
#define endl 'n'
#define rand() srand(time(0));
#define me(x) memset(x,0,sizeof(x));
#define foreach(it,a) for(__typeof((a).begin()) it=(a).begin();it!=(a).end();it++)
#define close() ios::sync_with_stdio(0);
typedef long long LL;
const int INF=0x3f3f3f3f;
const LL LINF=0x3f3f3f3f3f3f3f3fLL;
//const int dx[]={-1,0,1,0,-1,-1,1,1};
//const int dy[]={0,1,0,-1,1,-1,1,-1};
const int maxn=1e6+5;
const int maxx=1e6+3;
const double EPS=1e-7;
const int MOD=10000007;
typedef pair<int, int>P;
#define mod(x) ((x)%MOD);
template<class T>inline T min(T a,T b,T c) { return min(min(a,b),c);}
template<class T>inline T max(T a,T b,T c) { return max(max(a,b),c);}
template<class T>inline T min(T a,T b,T c,T d) { return min(min(a,b),min(c,d));}
template<class T>inline T max(T a,T b,T c,T d) { return max(max(a,b),max(c,d));}
//typedef tree<pt,null_type,less< pt >,rb_tree_tag,tree_order_statistics_node_update> rbtree;
/*lch[root] = build(L1,p-1,L2+1,L2+cnt);
rch[root] = build(p+1,R1,L2+cnt+1,R2);中前*/
/*lch[root] = build(L1,p-1,L2,L2+cnt-1);
rch[root] = build(p+1,R1,L2+cnt,R2-1);中后*/
long long gcd(long long a , long long b){if(b==0) return a;a%=b;return gcd(b,a);}
#define FOR(x,n,i) for(int i=x;i<=n;i++)
#define FOr(x,n,i) for(int i=x;i<n;i++)
#define W while
int T,L,t,l,r;
int main()
{
close();
cin>>L>>t>>T;
int val=T%(2*L);
if(val>=L)
l=L-(val-L);
else l=val;
T-=t;
T%=(2*L);
if(T>=L)
r=L-(T-L);
else r=T;
r=L-r;
if(r-l>0)
cout<<r-l<<endl;
else cout<<abs(r-l)<<endl;
}


最后

以上就是土豪乌冬面为你收集整理的2017 计蒜之道 初赛 第三场 A. 腾讯课堂的物理实验的全部内容,希望文章能够帮你解决2017 计蒜之道 初赛 第三场 A. 腾讯课堂的物理实验所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(47)

评论列表共有 0 条评论

立即
投稿
返回
顶部