我是靠谱客的博主 美丽摩托,最近开发中收集的这篇文章主要介绍HDU6077-Time To Get Up,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Time To Get Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 117 Accepted Submission(s): 101

Problem Description
Little Q’s clock is alarming! It’s time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has 5 alarms, and it’s just the first one, he can continue sleeping for a while.

Little Q’s clock uses a standard 7-segment LCD display for all digits, plus two small segments for the ”:”, and shows all times in a 24-hour format. The ”:” segments are on at all times.
这里写图片描述
Your job is to help Little Q read the time shown on his clock.

Input
The first line of the input contains an integer T(1≤T≤1440), denoting the number of test cases.

In each test case, there is an 7×21 ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ”X” indicates a segment that is on while ”.” indicates anything else. See the sample input for details.

Output
For each test case, print a single line containing a string t in the format of HH:MM, where t(00:00≤t≤23:59), denoting the time shown on the clock.

Sample Input
1
.XX…XX…..XX…XX.
X..X….X……X.X..X
X..X….X.X….X.X..X
……XX…..XX…XX.
X..X.X….X….X.X..X
X..X.X………X.X..X
.XX…XX…..XX…XX.

Sample Output
02:38

Source
2017 Multi-University Training Contest - Team 4

题目大意:给出时间的图像,打印出数字表示。
解题思路:模拟,观察数字的特征,哪里是实心的,哪里是空心的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;
const LL INF=1e18;
const int MAXN=1e3+100;
const int MOD=1e9+7;
char G[10][25];

int judge(int i)
{
    int l,r;
    if(i==1) l=0,r=3;
    else if(i==2) l=5,r=8;
    else if(i==3) l=12,r=15;
    else l=17,r=20;
    if(G[1][l+1]!='X')
    {
        if(G[4][l+1]=='X') return 4;
        else return 1;
    }else
    {
        if(G[2][r]!='X')
        {
            if(G[5][l]=='X') return 6;
            else return 5;
        }
        if(G[4][l+1]!='X')
        {
            if(G[2][l]=='X') return 0;
            else  return 7;
        }
        if(G[2][l]=='X')
        {
            if(G[5][l]=='X') return 8;
            else return 9;
        }
        if(G[5][l]=='X') return 2;
        else return 3;
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=1;i<=7;++i)
        {
            scanf("%s",&G[i]);
        }
        int h1=judge(1);
        int h2=judge(2);
        int h3=judge(3);
        int h4=judge(4);
        printf("%d%d:%d%dn",h1,h2,h3,h4);
    }
    return 0;
}
/*
.XX. . .XX. . . . .XX. . .XX.
X..X . ...X . . . ...X . X..X
X..X . ...X . X . ...X . X..X
.... . .XX. . . . .XX. . .XX.
X..X . X... . X . ...X . X..X
X..X . X... . . . ...X . X..X
.XX. . .XX. . . . .XX. . .XX.
*/

最后

以上就是美丽摩托为你收集整理的HDU6077-Time To Get Up的全部内容,希望文章能够帮你解决HDU6077-Time To Get Up所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(56)

评论列表共有 0 条评论

立即
投稿
返回
顶部