我是靠谱客的博主 潇洒发卡,最近开发中收集的这篇文章主要介绍ACM--最大公约数--HDOJ 1019--Least Common Multiple--水 Least Common Multiple,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
HDOJ题目地址:传送门
Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45286 Accepted Submission(s): 17030
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
题意题解:求给定你的一排数的最大公约数,这里特别要注意的一点就是需要用__int64,否则会WA
#include<stdio.h>
#include<iostream>
using namespace std;
__int64 lcm(__int64 a,__int64 b){
__int64 temp=a*b;
__int64 r=0;
while(b){
r=a%b;
a=b;
b=r;
}
return temp/a;
}
int main(){
int i ,n;
cin>>n;
while(n--){
int t;
__int64 a;
int b;
cin>>t;
cin>>a;
for(int i=1;i<t;i++){
cin>>b;
a=lcm(a,b);
}
printf("%I64dn",a);
}
}
最后
以上就是潇洒发卡为你收集整理的ACM--最大公约数--HDOJ 1019--Least Common Multiple--水 Least Common Multiple的全部内容,希望文章能够帮你解决ACM--最大公约数--HDOJ 1019--Least Common Multiple--水 Least Common Multiple所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复