我是靠谱客的博主 还单身咖啡,最近开发中收集的这篇文章主要介绍2136 Problem A Least Common Multiple,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

问题 A: Least Common Multiple
时间限制: 1 Sec 内存限制: 32 MB
献花: 73 解决: 54
[献花][花圈][TK题库]
题目描述
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
输入
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
输出
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
样例输入
2
2 3 5
3 4 6 12
样例输出
15
12

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
int gcd(int a, int b)
{
return !b ? a : gcd(b, a%b);
}
int main()
{
#ifdef _DEBUG
//freopen("data.txt", "r+", stdin);
fstream cin("data.txt");
#endif // _DEBUG
int n,m;
cin >> n;
while (n--)
{
int a, b, tmp;
cin >> m >> b;
--m;
while (m--)
{
cin >> a;
tmp = gcd(a, b);
b = b / tmp * a;
}
cout << b << endl;
}
#ifdef _DEBUG
cin.close();
#ifndef _CODEBLOCKS
std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG
return 0;
}
/**************************************************************
Problem: 2136
User: Sharwen
Language: C++
Result: 升仙
Time:0 ms
Memory:1704 kb
****************************************************************/

最后

以上就是还单身咖啡为你收集整理的2136 Problem A Least Common Multiple的全部内容,希望文章能够帮你解决2136 Problem A Least Common Multiple所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(49)

评论列表共有 0 条评论

立即
投稿
返回
顶部