我是靠谱客的博主 殷勤老师,最近开发中收集的这篇文章主要介绍Least Common Multiple(最小公倍数),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Least Common Multiple


The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.


Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296


解析:给一个整数串,求出这些数的最小公倍数。
思路:两个两个的求。

#include"stdio.h"
int mcm(long long x,long long y)
//find the greatest common divisor of two numbers
{
long long
t;
while(y)
{
t=x%y;
x=y;
y=t;
}
return x;
}
int main()
{
long long
n,m;
long long
x,y,t1;
while(scanf("%lld",&n)!=EOF)
{
while(n--)
{
scanf("%lld",&m);
scanf("%lld",&x);
while(--m)
{
scanf("%lld",&y);
t1=mcm(x,y);
x=x*y/t1;
//least common multiple is two numbers multiply divide their greatest common divisor
}
printf("%lldn",x);
}
}
return 0;
}


最后

以上就是殷勤老师为你收集整理的Least Common Multiple(最小公倍数)的全部内容,希望文章能够帮你解决Least Common Multiple(最小公倍数)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(52)

评论列表共有 0 条评论

立即
投稿
返回
顶部