我是靠谱客的博主 拼搏曲奇,这篇文章主要介绍hdu2101——A + B Problem Too,现在分享给大家,希望可以做个参考。

A + B Problem Too

This problem is also a A + B problem,but it has a little
difference,you should determine does (a+b) could be divided with
86.For example ,if (A+B)=98,you should output no for result.

Input

Each line will contain two integers A and B. Process to end of file.

Output

For each case, if(A+B)%86=0,output yes in one line,else output no in
one line.

Sample Input

1 1
8600 8600

Sample Output

no
yes

程序分析:while循环来多次输入,if判断(a+b)是否为86的倍数,!!程序要求换行!!
AC通过程序:

#include<stdio.h>
int main()
{
int a,b;
while(scanf("%d %d",&a,&b)!=EOF)
{
if((a+b)%86==0)
{
printf("yesn");
}else printf("non");
}
return 0;
}

小小改进后:

#include<stdio.h>
int main()
{
int a,b;
while(scanf("%d %d",&a,&b)!=EOF)
(a+b)%86==0?printf("yesn"):printf("non");
return 0;
}

最后

以上就是拼搏曲奇最近收集整理的关于hdu2101——A + B Problem Too的全部内容,更多相关hdu2101——A内容请搜索靠谱客的其他文章。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部