概述
An addition chain for n is an integer sequence <a0, a1,a2,…,am> with the following four properties:
a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1 <= k <= m) there exist two (not necessarily different) integers i and j (0 <= i, j <= k-1) with ak = ai + aj
You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1, 2, 3, 5> and <1, 2, 4, 5> are both valid solutions when you are asked for an addition chain for 5.
Input
The input will contain one or more test cases. Each test case consists of one line containing one integer n (1 <= n <= 100). Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Sample Input
5
7
12
15
77
0
Sample Output
1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
题意: 给定一个数n,需要组成一格序列序列的第一项为1,最后一项为n,这个序列中的每一项都能由比它小的两项相加而得,求能组成的最短序列,并输出。
思路: 把当前得到的序列中的所有数相加得到另一个序列,再对得到的序列中的每一项进行搜索直到其中一项为需要求的数。
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[1010],c[1010],w[1010],n,minn;
void dfs(int step)
{
if(step>=minn)
return ;
if(a[step-1]==n)//当搜索到n的时候进行更新
{
if(step<minn)//如果次序列小于之前得到的序列长度,进行更新
{
minn=step;
for(int i=1;i<step;i++)//把序列中的数存入w数组中
w[i]=a[i];
}
return ;
}
int s[1010];
int k=0;
for(int i=step-1;i>=1;i--)
{
for(int j=i;j>=1;j--)
{
if(a[i]+a[j]<=a[step-1]//把当前序列中的数两两相加,但要大于当前序列中最大值,这样求得的序列能尽可能短
break;
if(a[i]+a[j]<=n)//把小于n的数存入s数组中
s[k++]=a[i]+a[j];
}
}
sort(s,s+k);
for(int i=k-1;i>=0;i--)//对s数组中的每个数进行搜索
{
a[step]=s[i];
dfs(step+1);
}
}
int main()
{
while(~scanf("%d",&n)&&n)
{
minn=0x3f3f3f3f;
a[1]=1;
dfs(2);//从第二个数开始搜索
for(int i=1;i<minn-1;i++)
printf("%d ",w[i]);
printf("%dn",w[minn-1]);
}
return 0;
}
最后
以上就是激昂夕阳为你收集整理的Addition Chains ZOJ-1937的全部内容,希望文章能够帮你解决Addition Chains ZOJ-1937所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复