概述
Addition Chains
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5123 Accepted: 2767 Special Judge
Description
An addition chain for n is an integer sequence with the following four properties:
a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj
You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.
Input
The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.
Sample Input
5
7
12
15
77
0
Sample Output
1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
【分析】
搜索思路:
依次决定序列中每个位置填什么数。可枚举前面两个数的和作为新的数填充进序列。
剪枝:
对于每次枚举填什么数时,使用bool数组v判重,避免重复搜索某一个数。
为了让搜索的数尽可能快地逼近n,枚举时倒序循环以加快速度。
所求答案很小,可以使用迭代加深搜索,每次限制搜索深度,大于搜索深度就退出,第一次找到一组解就可以输出。
【代码】
//poj 2248 Addition Chains
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
int n,k;
int a[101];
inline bool dfs(int stp)
{
int i,j;
bool b[105];
memset(b,0,sizeof b);
if(stp>k)
{
if(a[k]==n) return 1;
return 0;
}
for(i=stp-1;i>=1;i--)
for(j=i;j>=1;j--)
if(a[j]+a[i]<=n && !b[a[i]+a[j]])
{
if(a[i]+a[j]<=a[stp-1]) return 0;
a[stp]=a[j]+a[i];
b[a[stp]]=1;
if(dfs(stp+1)) return 1;
}
return 0;
}
int main()
{
int i,j;
a[1]=1,a[2]=2;
while(scanf("%d",&n) && n)
{
if(n==1) {printf("1n");continue;}
if(n==2) {printf("1 2n");continue;}
fo(k,3,100)
if(dfs(3))
{
fo(i,1,k)
printf("%d ",a[i]);
printf("n");
break;
}
}
return 0;
}
最后
以上就是苹果芹菜为你收集整理的poj 2248 Addition Chains的全部内容,希望文章能够帮你解决poj 2248 Addition Chains所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复