我是靠谱客的博主 爱笑故事,最近开发中收集的这篇文章主要介绍【PAT甲级A1001 】A+B Format (20分)(c++),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

1001 A+B Format (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10 ^6≤a,b≤10 ^6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题意:

输入两个数,将两数之和表示为标准模式,即每个千位加个逗号。

思路:

需要将数字转换成字符串,应用到stl中to_string函数,正负加以区分,避免出现-,999这样的输出。

参考代码:

#include <iostream>
#include <string>
using namespace std;
int main() {
    int a,b;
    cin>>a>>b;
    string str=to_string(a+b);
    int len=str.length();
    if(str[0]=='-'){
        for(int pos=len-3;pos>1;pos-=3){
            str.insert(pos,",");
        }
    }
    else{
        for(int pos=len-3;pos>0;pos-=3){
            str.insert(pos,",");
        }
    }
    cout<<str<<endl;
    return 0;
}

如有错误,欢迎指正

最后

以上就是爱笑故事为你收集整理的【PAT甲级A1001 】A+B Format (20分)(c++)的全部内容,希望文章能够帮你解决【PAT甲级A1001 】A+B Format (20分)(c++)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(52)

评论列表共有 0 条评论

立即
投稿
返回
顶部