我是靠谱客的博主 沉默哑铃,最近开发中收集的这篇文章主要介绍pat甲级1001,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

代码

#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
	int a, b;
	cin >> a >> b;
	int c = a + b;
	if (c < 0)
	{
		cout << "-";
		c = -c;
	}
	if (c >= 1000000)
	{
		cout << c / 1000000 << "," <<setw(3)<<setfill('0')<< c / 1000 % 1000 << "," <<setw(3)<<setfill('0')<< c % 1000;
	}
  if (c >= 1000&&c<1000000)
	{
		cout << c / 1000 << "," <<setw(3)<<setfill('0')<<c % 1000;
	}
	if(c<1000)
	{
		cout << c;
	}
	return 0;
}

 

最后

以上就是沉默哑铃为你收集整理的pat甲级1001的全部内容,希望文章能够帮你解决pat甲级1001所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(61)

评论列表共有 0 条评论

立即
投稿
返回
顶部