我是靠谱客的博主 斯文大雁,最近开发中收集的这篇文章主要介绍2017多校联合第五场1011/hdu6095Rikka with Competition(排序) Rikka with Competition,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 396    Accepted Submission(s): 328


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow.  n  players will take part in it. The  i th player’s strength point is  ai .

If there is a match between the  i th player plays and the  j th player, the result will be related to  |aiaj| . If  |aiaj|>K , the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After  n1  matches, the last player will be the winner.

Now, Yuta shows the numbers  n,K  and the array  a  and he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t100) , the number of the testcases. And there are no more than  2  testcases with  n>1000 .

For each testcase, the first line contains two numbers  n,K(1n105,0K<109) .

The second line contains  n  numbers  ai(1ai109) .
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
  
  
2 5 3 1 5 9 6 3 5 2 1 5 9 6 3
 

Sample Output
  
  
5 1
 

Source
2017 Multi-University Training Contest - Team 5
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6095  6094  6093  6092  6091 
 

Statistic |  Submit |  Discuss |  Note

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int i,j,k,p,t;
    int n;
    int a[100001];
    int tot;
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        tot=1;
        for(i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        sort(a+1,a+n+1);
        for(i=n-1;i>=1;i--)
        {
            if(a[i+1]-a[i]<=k)tot++;
            else break;
        }
        cout<<tot<<endl;
    }
    return 0;
}


最后

以上就是斯文大雁为你收集整理的2017多校联合第五场1011/hdu6095Rikka with Competition(排序) Rikka with Competition的全部内容,希望文章能够帮你解决2017多校联合第五场1011/hdu6095Rikka with Competition(排序) Rikka with Competition所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(56)

评论列表共有 0 条评论

立即
投稿
返回
顶部