我是靠谱客的博主 甜甜飞机,最近开发中收集的这篇文章主要介绍哈夫曼树-例题,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2… N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input
3
8
5
8

Sample Output
34

Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:一块木板分割成N块,输入每块的长度,切割木板的长度即为花费的钱,求最小花费。
思路: 利用哈夫曼树和优先队列解决,让队列中的数从小到大排列,每次让最小的两个相加,让相加的两个数出队列,得到的和放入队尾,然后让和叠加,重复操作,得出结果。

#include<stdio.h>
#include<string.h>
#include<queue>//优先队列
#include<algorithm>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        priority_queue<int,vector<int>,greater<int> > q;//最后两个 > 要分开,否则就是右移符号
        int i,s,a,b,m,sum=0;                            //greater的作用是使进入队列的数从小到大排列
        for(i=0;i<n;i++)                                //less从大到小 priority_queue<int> q;默认less;    
        {
            scanf("%d",&m);
            q.push(m);//入队尾,只能一个一个放,不能放数组;
        }
        while(q.size()>=2)//核心代码
         {  a=q.top();//首对列
            q.pop();//首队列出队列
            b=q.top();
            q.pop();
            s=a+b;
            q.push(s);
            sum=sum+s;
        }
        printf("%dn",sum);
    }
    return 0;
}

最后

以上就是甜甜飞机为你收集整理的哈夫曼树-例题的全部内容,希望文章能够帮你解决哈夫曼树-例题所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(57)

评论列表共有 0 条评论

立即
投稿
返回
顶部