概述
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.
Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
Input
First line contains two integers stand for N and M. Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. Process to the end of the file.
Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
Sample Output
13
BFS 广搜优先队列
#include<bits/stdc++.h>
using namespace std;
char ma[205][205];
int dir[][2] = { 1,0,-1,0,0,1,0,-1 };
int n, m;
struct ff
{
int x, y, time;
friend bool operator<(ff n1, ff n2)
{
return n2.time < n1.time;
}
}p, s, t;
void bfs(int a, int b)
{
priority_queue<ff>q;
p.x = a, p.y = b, p.time = 0;
q.push(p);
while (!q.empty())
{
s = q.top();
q.pop();
for (int i = 0; i < 4; i++)
{
t.x = s.x + dir[i][0];
t.y = s.y + dir[i][1];
if (t.x >= 0 && t.x < n&&t.y >= 0 && t.y < m&&ma[t.x][t.y]!='#')
{
if (ma[t.x][t.y] == 'a')
{
printf("%dn", s.time + 1);
return;
}
if (ma[t.x][t.y] == 'x')
{
t.time = s.time + 2;
}
if (ma[t.x][t.y] == '.')
{
t.time = s.time + 1;
}
q.push(t);
ma[t.x][t.y] = '#';
}
}
}
printf("Poor ANGEL has to stay in the prison all his life.n");
}
int main()
{
int xx, yy;
while (~scanf("%d%d", &n, &m))
{
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
cin >> ma[i][j];
if (ma[i][j] == 'r')
{
xx = i;
yy = j;
}
}
}
bfs(xx, yy);
}
}
最后
以上就是帅气书本为你收集整理的HDU 1242 Rescue的全部内容,希望文章能够帮你解决HDU 1242 Rescue所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复