我是靠谱客的博主 纯真柚子,最近开发中收集的这篇文章主要介绍HDU 1242 Rescue(BFS+优先队列)                                                  Rescue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目链接:点击打开链接

                                                  Rescue

                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                          Total Submission(s): 23823    Accepted Submission(s): 8417


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
ZOJ Monthly, October 2003

题意:X代表卫兵,a代表终点,r代表起始点,.代表路,#代表墙

路花费一秒,x花费两秒

问到达终点的最少时间

因为r可能有很多个,所以从a点开始BFS,找到的第一个r为最短时间,遇到’x’点是,时间+2,如果用普通的队列就并不能保证每次出队的是时间最小的元素,所以要用优先队列。

第一道优先队列题,其实还不会~~

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int visit[210][210],n,m;int dir[4][2]={-1,0,0,-1,0,1,1,0};
char s[210][210];
struct node
{
    int x,y,step;
    friend bool operator < (const node &a,const node &b)  
    {
        return a.step>b.step;
    }
};
int bfs(int a,int b)
{
   int i;
   priority_queue<node>q;
   node now,next;
   now.x=a;now.y=b;now.step=0;
   visit[now.x][now.y]=1;
   q.push(now);
   while(!q.empty())
   {
       now=q.top();
       q.pop();
       if(s[now.x][now.y]=='r') return now.step;
       for(i=0;i<4;i++)
       {
           next.x=now.x+dir[i][0];
           next.y=now.y+dir[i][1];
           if(next.x>=0&&next.x<n&&next.y>=0&&next.y<m&&s[next.x][next.y]!='#'&&visit[next.x][next.y]!=1)
           {
               visit[next.x][next.y]=1;
               if(s[next.x][next.y]=='x') next.step=now.step+2;
               else next.step=now.step+1;
               q.push(next);
           }
       }
   }
   return -1;

}
int main()
{
     int  i,j,a,b,c,d,ans;
     while(scanf("%d%d",&n,&m)!=EOF)
     {
         memset(visit,0,sizeof(visit));
         for(i=0;i<n;i++)
         scanf("%s",s[i]);
         for(i=0;i<n;i++)
         {
            for(j=0;j<m;j++)
            {
              if(s[i][j]=='a') {a=i;b=j;break;}
            }
         }
        ans=bfs(a,b);
        if(ans==-1) printf("Poor ANGEL has to stay in the prison all his life.n");
        else printf("%dn",ans);
     }
}



最后

以上就是纯真柚子为你收集整理的HDU 1242 Rescue(BFS+优先队列)                                                  Rescue的全部内容,希望文章能够帮你解决HDU 1242 Rescue(BFS+优先队列)                                                  Rescue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(51)

评论列表共有 0 条评论

立即
投稿
返回
顶部