我是靠谱客的博主 文艺龙猫,最近开发中收集的这篇文章主要介绍HDU 1242 Rescue(bfs+优先队列)Rescue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24119    Accepted Submission(s): 8504


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
ZOJ Monthly, October 2003
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1240  1010  1072  1253  1372 
注意r有多个,刚开始没注意一直WA;
 
<pre name="code" class="cpp">#include <stdio.h>    
#include <string.h>    
#include <queue>    
using namespace std;    
struct node    
{    
    int x,y,step;    
    friend bool operator<(node n1,node n2)    
    {    
        return n2.step<n1.step;    
    }    
};    
    
int n,m,vis[205][205];    
char map[205][205];    
int ex,ey,sx,sy;    
int dis[4][2] = {1,0,-1,0,0,1,0,-1};    
    
int check(int x,int y)    
{    
    if(x<0 || y<0 || x>=n || y>=m || vis[x][y] || map[x][y] == '#')    
    return 0;    
    return 1;    
}    
    
int bfs()    
{    
    int i;    
    priority_queue<node> Q;    
    node a,next;    
    a.x = sx;    
    a.y = sy;    
    a.step = 0;    
    Q.push(a);    
    vis[sx][sy] = 1;    
    while(!Q.empty())    
    {    
        a = Q.top();    
        Q.pop();    
        if(a.x == ex && a.y == ey)    
        return a.step;    
        for(i = 0; i<4; i++)    
        {    
            next = a;    
            next.x+=dis[i][0];    
            next.y+=dis[i][1];    
            if(check(next.x,next.y))    
            {
           	    next.step++;    
                if(map[next.x][next.y] == 'x')    
                next.step++;        
                vis[next.x][next.y] = 1;    
                Q.push(next);       
			}   
            
        }    
    }    
    return 0;    
}     
int main()    
{    
    int i,j;    
    while(~scanf("%d%d",&n,&m))    
    {    
        for(i = 0; i<n; i++)    
        {    
            scanf("%s",map[i]);    
            for(j = 0; map[i][j]; j++)    
            {    
                if(map[i][j] == 'r')    
                {    
                    sx = i;    
                    sy = j;    
                }    
                else if(map[i][j] == 'a')    
                {    
                    ex = i;    
                    ey = j;    
                }    
            }    
        }    
        memset(vis,0,sizeof(vis));    
        int ans = 0;    
        ans = bfs();    
        if(ans)    
        printf("%dn",ans);    
        else    
        printf("Poor ANGEL has to stay in the prison all his life.n");    
    }    
    return 0;    
}  


 
 

最后

以上就是文艺龙猫为你收集整理的HDU 1242 Rescue(bfs+优先队列)Rescue的全部内容,希望文章能够帮你解决HDU 1242 Rescue(bfs+优先队列)Rescue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部