我是靠谱客的博主 无辜悟空,这篇文章主要介绍HDU1242Rescue,现在分享给大家,希望可以做个参考。

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27043    Accepted Submission(s): 9576


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
复制代码
1
2
3
4
5
6
7
8
9
10
11
12
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
复制代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
13
bfs迷宫题,学会使用结构体和方向数组
使用优先队列求得最优解~
读入图的过程要注意。
复制代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;

#define Maxn 205

char mat[Maxn][Maxn];
int vis[Maxn][Maxn];
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int row,col;

struct Node
{
	int x,y;
	int time;
    friend bool operator < (const Node &a,const Node &b)  
	{
		return a.time>b.time;
	}
};

Node start;

int bfs(Node source)
{

    memset(vis,0,sizeof(vis));
    priority_queue<Node> q;
    while(!q.empty()) q.pop();
    q.push(source);
    vis[source.x][source.y]=1;
    while(!q.empty())
    {
        int i;
        Node next;
        Node a=q.top();
        q.pop();
        for(i=0;i<4;i++)
        {
            next.x=a.x+dir[i][0];
            next.y=a.y+dir[i][1];
            if(next.x<0||next.x>=row||next.y<0||next.y>=col||mat[next.x][next.y]=='#')
                continue;
            if(vis[next.x][next.y]) continue;
            vis[next.x][next.y]=1;
            if(mat[next.x][next.y]=='x') next.time=a.time+2;
            if(mat[next.x][next.y]=='.') next.time=a.time+1;
            if(mat[next.x][next.y]=='r') {return a.time+1;}
            q.push(next);
        }
    }
    return -1;
}

int main()
{
	int i,j;
	int ans;
	while(scanf("%d%d",&row,&col)!=EOF)
	{
		for(i=0;i<row;i++)
		{
		    for(j=0;j<col;j++)
            {
                cin>>mat[i][j];
                //scanf("%c",&mat[i][j]);为什么用scanf不行???
                if(mat[i][j]=='a')
		        {
			        start.x=i;
			        start.y=j;
			        start.time=0;
		        }
            }
            getchar();
		}
		/*for(i=0;i<row;i++)
        {
            for(j=0;j<col;j++)
            {
                cout<<mat[i][j];

            cout<<endl;
        }*/
        ans=bfs(start);
		if(ans==-1)
		printf("Poor ANGEL has to stay in the prison all his life.n");
		else
		printf("%dn",ans);
	}
	return 0;
}


最后

以上就是无辜悟空最近收集整理的关于HDU1242Rescue的全部内容,更多相关HDU1242Rescue内容请搜索靠谱客的其他文章。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(65)

评论列表共有 0 条评论

立即
投稿
返回
顶部