我是靠谱客的博主 大胆大门,最近开发中收集的这篇文章主要介绍HDU 1242 RescueRescue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10446    Accepted Submission(s): 3828

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.
Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

 

Input
First line contains two integers stand for N and M.
Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.  
Process to the end of the file.
 

 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."  
 

 

Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........
 

 

Sample Output
13
 

 

Author
CHEN, Xue
 

 

Source
ZOJ Monthly, October 2003
 

 

Recommend
Eddy
 
 
 
 
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn=220;

char map[maxn][maxn];
int n,m,visited[maxn][maxn];
int si,sj,ei,ej;

struct node{
    int x,y;
    int step;
    bool operator < (const node &a) const{
        return a.step<step;
    }
};

int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};

int BFS(int x,int y){
    priority_queue<node> myqueue;
    while(!myqueue.empty())
        myqueue.pop();
    node cur,next;
    cur.x=x;cur.y=y;cur.step=0;
    visited[x][y]=1;
    myqueue.push(cur);
    int i;
    while(!myqueue.empty()){
        cur=myqueue.top();
        myqueue.pop();
        if(cur.x==ei && cur.y==ej)
            return cur.step;
        for(i=0;i<4;i++){
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            if(next.x<0 || next.x>=n || next.y<0 || next.y>=m || map[next.x][next.y]=='#')
                continue;
            if(!visited[next.x][next.y]){
                visited[next.x][next.y]=1;
                if(map[next.x][next.y]=='x')
                    next.step=cur.step+2;
                else
                    next.step=cur.step+1;
                myqueue.push(next);
            }
        }
    }
    return -1;
}

int main(){

    //freopen("input.txt","r",stdin);

    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(visited,0,sizeof(visited));
        for(i=0;i<n;i++)
            for(j=0;j<m;j++){
                cin>>map[i][j];
                if(map[i][j]=='r'){
                    si=i;sj=j;
                    visited[i][j]=1;
                }
                if(map[i][j]=='a'){
                    ei=i;ej=j;
                }
            }
        int ans=BFS(si,sj);
        if(ans!=-1)
            printf("%dn",ans);
        else
            printf("Poor ANGEL has to stay in the prison all his life.n");
    }
    return 0;
}

 

最后

以上就是大胆大门为你收集整理的HDU 1242 RescueRescue的全部内容,希望文章能够帮你解决HDU 1242 RescueRescue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部