概述
Max Sequence
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 17678 | Accepted: 7401 |
Description
Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N).
You should output S.
You should output S.
Input
The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.
Output
For each test of the input, print a line containing S.
Sample Input
5 -5 9 -5 11 20 0
Sample Output
40
Source
POJ Monthly--2005.08.28,Li Haoyuan
题解:这个题2479差不多,具体可以看2479的题解,不过感觉这道题的测试数据要比2479弱一些,轻松AC
//主要是刷几道dp练练手
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1e6+7, inf = -1e9+7;
int a[maxn], ls[maxn], rs[maxn], rst[maxn], s;
int main()
{
int n;
while (~scanf("%d", &n) && n)
{
for (int i=0; i<n; i++)
scanf("%d", &a[i]);
ls[0] = a[0], rs[n-1] = rst[n-1] = a[n-1], s = inf;
for (int i=1; i<n; i++)
ls[i] = max(ls[i-1]+a[i], a[i]);
for (int i=n-2; i>=0; i--)
rs[i] = max(rs[i+1]+a[i], a[i]),
rst[i] = max(rst[i+1], rs[i]);
for (int i=1; i<n; i++)
s = max(s, ls[i-1]+rst[i]);
printf("%dn", s);
}
return 0;
}
转载于:https://www.cnblogs.com/fayne/p/7224786.html
最后
以上就是粗犷裙子为你收集整理的POJ 2593 Max Sequence的全部内容,希望文章能够帮你解决POJ 2593 Max Sequence所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复