我是靠谱客的博主 自信金针菇,最近开发中收集的这篇文章主要介绍HDU 5272 Dylans loves numbers Dylans loves numbers,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5272


题面:

Dylans loves numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 241    Accepted Submission(s): 160


Problem Description
Who is Dylans?You can find his ID in UOJ and Codeforces.
His another ID is s1451900 in BestCoder.

And now today's problems are all about him.

Dylans is given a number  N .
He wants to find out how many groups of "1" in its Binary representation.

If there are some "0"(at least one)that are between two "1",
then we call these two "1" are not in a group,otherwise they are in a group.
 

Input
In the first line there is a number  T .

T  is the test number.

In the next  T  lines there is a number  N .

0N1018,T1000
 

Output
For each test case,output an answer.
 

Sample Input
  
  
1 5
 

Sample Output
  
  
2
 

Source
BestCoder Round #45
 


解题:

就是求将一个数转成二进制后,其中有几块“1”。因为首位肯定为1,所以只要往后多加一个“0”。然后数连续“10”的个数即可。


代码:

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
	int t,x,cnt;
	unsigned long long n;
	string s;
	cin>>t;
	while(t--)
	{
		cin>>n;
		cnt=0;
		s="";
		while(n)
		{
		  x=n&1;
		  if(x)	s+='1';
		  else s+='0';
		  n>>=1;
		}
		reverse(s.begin(),s.end());
		s+='0';
		int len=s.length()-1;
		for(int i=0;i<len;i++)
		{
			if(s[i]=='1'&&s[i+1]=='0')
			cnt++;
		}
		cout<<cnt<<endl;
	}
	return 0;
} 


最后

以上就是自信金针菇为你收集整理的HDU 5272 Dylans loves numbers Dylans loves numbers的全部内容,希望文章能够帮你解决HDU 5272 Dylans loves numbers Dylans loves numbers所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(54)

评论列表共有 0 条评论

立即
投稿
返回
顶部