我是靠谱客的博主 典雅冷风,最近开发中收集的这篇文章主要介绍hdu2604之矩阵快速幂 Queuing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2003    Accepted Submission(s): 938


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10  6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=4;
int array[MAX][MAX],sum[MAX][MAX];

void MatrixMult(int a[MAX][MAX],int b[MAX][MAX],int &mod){
	int c[MAX][MAX]={0};
	for(int i=0;i<MAX;++i){
		for(int j=0;j<MAX;++j){
			for(int k=0;k<MAX;++k){
				c[i][j]+=a[i][k]*b[k][j];
			}
		}
	}
	for(int i=0;i<MAX;++i){
		for(int j=0;j<MAX;++j)a[i][j]=c[i][j]%mod;
	}
}

int MatrixPow(int k,int &mod){
	for(int i=0;i<MAX;++i){
		for(int j=0;j<MAX;++j)sum[i][j]=(i == j);
	}
	array[0][0]=array[0][1]=array[0][2]=0,array[0][3]=1;
	array[1][1]=array[1][2]=0,array[1][0]=array[1][3]=1;
	array[2][0]=array[2][3]=0,array[2][1]=array[2][2]=1;
	array[3][0]=array[3][1]=array[3][3]=0,array[3][2]=1;
	while(k){
		if(k&1)MatrixMult(sum,array,mod);
		MatrixMult(array,array,mod);
		k>>=1;
	}
	int ans=0;
	for(int i=0;i<MAX;++i)ans=(ans+sum[i][0]+sum[i][1]+sum[i][2]+sum[i][3])%mod;
	return ans;
}

int main(){
	int n,m;
	while(cin>>n>>m){
		/*for(int i=3;i<=n;++i){//推出递推公式了就可以用矩阵快速幂了 
			dp[i][0]=dp[i-1][3];
			dp[i][1]=(dp[i-1][0]+dp[i-1][3])%m;
			dp[i][2]=(dp[i-1][1]+dp[i-1][2])%m;
			dp[i][3]=dp[i-1][2];
		}*/
		if(n == 0)cout<<0<<endl;
		else if(n == 1)cout<<2%m<<endl;
		else if(n == 2)cout<<4%m<<endl;
		else{
			cout<<MatrixPow(n-2,m)<<endl;
			//cout<<(dp[n][0]+dp[n][1]+dp[n][2]+dp[n][3])%m<<endl;
		}
	}
	return 0;
}



最后

以上就是典雅冷风为你收集整理的hdu2604之矩阵快速幂 Queuing的全部内容,希望文章能够帮你解决hdu2604之矩阵快速幂 Queuing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(41)

评论列表共有 0 条评论

立即
投稿
返回
顶部