我是靠谱客的博主 无奈唇彩,最近开发中收集的这篇文章主要介绍HDU 1020 Encoding Encoding,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28510    Accepted Submission(s): 12635


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC A2B3C

水题 不说话

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

char s[10005];
struct point
{
  char c;
  int count;
}a[10005];

int main(void)
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        while(n--)
        {
            scanf("%s",s);
            int l=strlen(s);
            int p=1;

            a[p].count=1;
            a[p].c=s[0];
            for(int i=1;i<l;i++)
            {
                if(s[i]!=s[i-1])
                {
                    a[++p].count=1;
                    a[p].c=s[i];
                }
                else a[p].count++;
            }
            for(int i=1;i<=p;i++)
            {
                if(a[i].count==1)
                    printf("%c",a[i].c);
                else
                    printf("%d%c",a[i].count,a[i].c);
            }
            printf("n");

        }
    }
    return 0;
}


最后

以上就是无奈唇彩为你收集整理的HDU 1020 Encoding Encoding的全部内容,希望文章能够帮你解决HDU 1020 Encoding Encoding所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(63)

评论列表共有 0 条评论

立即
投稿
返回
顶部