我是靠谱客的博主 沉静小丸子,最近开发中收集的这篇文章主要介绍UPC 问题 L: Shift only,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

问题 L: Shift only
时间限制: 1 Sec 内存限制: 128 MB
提交: 286 解决: 223
[提交] [状态] [讨论版] [命题人:admin]
题目描述

There are N positive integers written on a blackboard: A1,…,AN.
Snuke can perform the following operation when all integers on the blackboard are even:
Replace each integer X on the blackboard by X divided by 2.
Find the maximum possible number of operations that Snuke can perform.

Constraints
1≤N≤200
1≤Ai≤109

输入

Input is given from Standard Input in the following format:
N
A1 A2 … AN

输出

Print the maximum possible number of operations that Snuke can perform.

样例输入

3
8 12 40

样例输出

2

#include<bits/stdc++.h>
using namespace std;
int del(int a[],int n,int flag)
{
    for(int i=0;i<n;i++){
        a[i]=a[i]/2;
        if(a[i]%2!=0)
            flag=0;
    }
    return flag;
}
int main()
{
    int n;cin>>n;
    int num[n];
    int flag=1;
    int cnt=0;
    for(int i=0;i<n;i++)
    {
        cin>>num[i];
        if(num[i]%2!=0)
            flag=0;
    }
    if(flag==0)
        cout<<"0"<<endl;
    else
    {
        while(flag==1){
            flag=del(num,n,flag);
            cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}

最后

以上就是沉静小丸子为你收集整理的UPC 问题 L: Shift only的全部内容,希望文章能够帮你解决UPC 问题 L: Shift only所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部