概述
读入n值及n个整数,建立顺序表并遍历输出。
输入格式:
读入n及n个整数
输出格式:
输出n个整数,以空格分隔(最后一个数的后面没有空格)。
输入样例:
在这里给出一组输入。例如:
4
-3 10 20 78
结尾无空行
输出样例:
在这里给出相应的输出。例如:
-3 10 20 78
结尾无空行
代码如下:
#include<stdio.h>
#include <stdlib.h>
#include <malloc.h>
typedef struct{
int *p;
int last;
}stu,*list;
int main()
{
list t;
int n;
scanf("%d",&n);
t=(list)malloc(sizeof(stu));
t->p=(int*)malloc(n*sizeof(int));
t->last=n-1;
for(int i=0; i<n; i++)
{
scanf("%d",&t->p[i]);
}
for(int i=0; i<=t->last; i++)
{
if(i<n-1)
printf("%d ",t->p[i]);
else
printf("%d",t->p[i]);
}
return 0;
}
最后
以上就是等待眼神为你收集整理的7-1 顺序表的建立及遍历的全部内容,希望文章能够帮你解决7-1 顺序表的建立及遍历所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复